logo
down
shadow

React Native : Could not find com.android.tools.build:gradle:2.2.3


React Native : Could not find com.android.tools.build:gradle:2.2.3

By : user2173669
Date : October 20 2020, 08:10 AM
Hope this helps It seems com.android.tools.build:gradle:2.2.3 was removed from the jcenter repository.
Try adding this code to your top-level build.gradle file:
code :
subprojects {project ->
    if (project.name.contains('react-native-fetch-blob')) {
        buildscript {
            repositories {
                maven { url "https://dl.bintray.com/android/android-tools/"  }
            }    
        }
    }
}


Share : facebook icon twitter icon
Could not resolve com.android.tools.build:gradle:3.1.4, react-native run-android

Could not resolve com.android.tools.build:gradle:3.1.4, react-native run-android


By : user1831002
Date : March 29 2020, 07:55 AM
fixed the issue. Will look into that further Actually, I was able to get past my problem, by uninstalling and re-installing everything (java jdk, react-native-cli, android-studio, watchman).
It probably was a java issue, because on my first react-native setup, I mistakenly installed java-jdk-11, which is not compatible with android sdk that react-native depends on, and java-jdk-8 is needed instead (as mentioned here, for example). But when I downgraded to jdk-8 with all the other stuff already installed, it wasn't working, due to some certification related issue, that I couldn't fix as suggested elsewhere.
React-Native-Could not resolve all files for configuration ':classpath'. Could not find com.android.tools.build:gradle:3

React-Native-Could not resolve all files for configuration ':classpath'. Could not find com.android.tools.build:gradle:3


By : 2scooter
Date : March 29 2020, 07:55 AM
fixed the issue. Will look into that further Seems like your Could not find com.android.tools.build:gradle:3.4.1. issue is solved by changing the version code 3.4.1 to 3.3.2.
Another problem exists because in 3.3.2 gradle version you have to use minimum gradle distribution version 4.10.1. To solve this open gradle-wrapper.properties file and use this line to
code :
distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.zip
React Native Could not find com.android.tools.build:gradle:3.4.2

React Native Could not find com.android.tools.build:gradle:3.4.2


By : user3306910
Date : March 29 2020, 07:55 AM
will help you all for the Answers I think I will provide the answer here for others to use.
my issue was due to the version conflict of gradle and android studi plugin.
react-native run-android Could not find com.android.tools.build:gradle:3.0.1

react-native run-android Could not find com.android.tools.build:gradle:3.0.1


By : lukeavsec
Date : March 29 2020, 07:55 AM
it should still fix some issue It is usually a problem with your repositories in your gradle files.
for me worked to modify the build.gradle like this:
code :
buildscript {
    repositories {
        mavenLocal()
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.1'
    }
}
React-native project Build failed: Could not find com.android.tools.lint:lint-gradle:26.1.0

React-native project Build failed: Could not find com.android.tools.lint:lint-gradle:26.1.0


By : ZNing
Date : March 29 2020, 07:55 AM
it should still fix some issue I have some issues trying to generate a new release of my apk. (However the app runs normally in debug with react-native run-android) , Have you tried with google() before jcenter() ? It worked for me:
code :
buildscript {
    repositories {
        google()
        jcenter()
        gradlePluginPortal()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.1'
        // NOTE: Do not place your application dependencies here;
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}
Related Posts Related Posts :
  • How to employ keyed-hash message authentication code (HMAC) with Android Keystore
  • Prevent inviting existing users or previously invited
  • How to overwrite windowSoftInputMode using edit-config tag in cordova
  • Difference between Loader and AsyncTask
  • In Firebase Android, retrieve the value of a child node and save it in a boolean variable
  • when i scroll the custom list in my android app then the favorite icon which is part of the custom adapter changes on it
  • adding room dependency gives manifest merge error
  • Visibility of RelativeLayout change on scrolling Gridview
  • Strange LiveData behavior vs ObservableField
  • Which layout is used for clash of clans home screen? We can scroll it horizontal as well as vertical. Please illuminate
  • RxJava: Know when observable is finished and return Boolean Observable to the caller
  • how to use savedInstanceState to save camera information when the orientation change occure
  • Style React-Native via Styles.xml
  • Keyboard won't show after calling InputMethodManager.showSoftInput
  • Compiling ffmpeg for Android on OSX
  • Button does not get clicked on the first attempt
  • AR Core performance, learning curve and comparison with other frameworks
  • Codename one : Attaching images to email message fails
  • Error: Unsupported type 'viewItem' in Android build
  • setLayoutParams on ConstraintLayout does not change size
  • How to profile the fetch time of the android gradle libraries
  • Kotlin setOnclickListener
  • Naming convention for methods returning RxJava's Completable
  • Conv3D not working
  • FFmpeg audio video merge command
  • Do you have to use gradle-experimental for JNI?
  • How to get key hashes for facebook for facebook app?
  • ZXing not calling onActivityResult, When scanning QR Code
  • Integration of Android Native module with existing Xamarin Native Project
  • Restore RecyclerView state after rotating
  • ViewModelProviders java.lang.RuntimeException trying to instantiate class which inherit AndroidViewModel
  • SKD19 vs SDK24 - Usage of API documented as @since 1.8+
  • filter option in list view fragment activity
  • Picture from camera not showing up in second activity
  • How to change imageview according to screen size
  • How to copy Android Studio project to remote Git (NOT GitHub) server
  • How to get React-Native to announce specific accessibility message via AccessibiliyManager?
  • Change colors of com.tech.freak.wizardpager.ui.StepPagerStrip
  • Android fullscreen activity shows ActionBar
  • Turn on the screen when timer calls onFinish()
  • Would like a bit of clarification with SQLite database's onUpgrade method
  • Use ObjectBox with Libgdx
  • How to make combine Gregorian and Hijri calendar in Android?
  • Try to read text file from sdcard in other language
  • "App not installed" message when installed apk
  • How to execute a designated test suite class in Firebase Test Lab
  • play music with background service
  • background not visible on LG G3
  • should every View have an id?
  • Realm object server sync on low connection.
  • Correct way to add more views to adapter
  • Getting error in android support library
  • Instant app zip uploading error
  • "No emulator installed" error in Android Studio even though Intel HAXM is up and running
  • AsyncTask without leaks
  • SQLiteException : No such table found whereas a table was created
  • Using @Component.Builder with constructor params
  • No injector was found for fragment dagger 2.11
  • Android Volley Https SSL self signed and Google Maps API
  • Why does the onClickListener not work anymore in this example?
  • shadow
    Privacy Policy - Terms - Contact Us © voile276.org