logo
Tags down

shadow

Protobuf Gradle plugin version 0.8.6 and higher vs Project 'flutter_blue' is using version 0.8.3


By : but sophon
Date : October 18 2020, 08:10 AM
I wish this help you I created a pull request to fix this.
https://github.com/pauldemarco/flutter_blue/pull/147
code :
 dependencies {
        classpath 'com.android.tools.build:gradle:3.1.3'
        classpath 'com.google.protobuf:protobuf-gradle-plugin:0.8.3' <- Remove
        classpath 'com.google.protobuf:protobuf-gradle-plugin:0.8.6' <-- Add
    }


Share : facebook icon twitter icon

The Android Gradle plugin supports only Crashlytics Gradle plugin version 1.25.4 and higher. Project '***' is using vers


By : Doug Paulin
Date : March 29 2020, 07:55 AM
Does that help The "Crashlytics Gradle plugin" is found in gradle in the io.fabric.tools:gradle package as mentioned on https://firebase.google.com/docs/crashlytics/get-started#android
You should find that in your projects root build.gradle file. Similar to this
code :
buildscript {
    repositories {
        jcenter()
        google()
        maven { url 'https://maven.fabric.io/public' }
    }
    dependencies {
        classpath 'io.fabric.tools:gradle:1.25.1'
        ...
    }
}

allprojects {
    ...
classpath 'io.fabric.tools:gradle:1.+' // or even ...:gradle:+'

ERROR: The Android Gradle plugin supports only Kotlin Gradle plugin version 1.3.0 and higher


By : Mike
Date : March 29 2020, 07:55 AM
This might help you The error is caused by the old version of Kotlin in your project level file, you can update it to the latest version like so:
code :
ext.kotlin_version = '1.3.21'

Flutter | The Android Gradle plugin supports only Kotlin Gradle plugin version 1.3.0 and higher


By : user2416960
Date : March 29 2020, 07:55 AM
this one helps. You can find which package depends on google_api_availability by running flutter packages pub deps on the root of the project - this will list all the direct and transitive dependencies of your project in a tree view.
I couldn't find a way to display the plugin dependencies of a package - I guess you'll only find out once you try to build it.

The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.51 and higher. Project 'MyApp' is using version


By : TheBigFridge
Date : March 29 2020, 07:55 AM
help you fix your problem I have solved it. Just changed Kotlin version to 1.2.51 in Gradle and it worked perfectly.

ERROR: The Android Gradle plugin supports only Butterknife Gradle plugin version 9.0.0-rc2 and higher


By : Dinesh Sharma
Date : March 29 2020, 07:55 AM
I wish this help you Are you using androidx in your app/library? If so, I would bump the butterknife version to the stable 10.0.0 version, otherwise update to the stable 9.0.0 one.
Without androidx:
code :
implementation 'com.jakewharton:butterknife:9.0.0'
annotationProcessor 'com.jakewharton:butterknife-compiler:9.0.0'
implementation 'com.jakewharton:butterknife:10.0.0'
annotationProcessor 'com.jakewharton:butterknife-compiler:10.0.0'
shadow
Privacy Policy - Terms - Contact Us © voile276.org