logo
Tags down

shadow

Failed to resolve: com.google.android.exoplayer:extension-mediasession:2.8.4


By : user2175037
Date : October 16 2020, 08:10 PM
I think the issue was by ths following , Was facing the same issue. Solved by adding url 'https://google.bintray.com/exoplayer/' to buld.gradle at a project level within allprojects section.
code :
allprojects {
repositories {
    google()
    jcenter()
    maven {
        url 'https://google.bintray.com/exoplayer/'
    }
}


Share : facebook icon twitter icon

Exoplayer r1.5.2 failed to resolve com.google.android.exoplayer:exoplayer:r1.5.2


By : Fred
Date : March 29 2020, 07:55 AM
will help you I had this issue as well: I added compile 'com.google.android.exoplayer:exoplayer:r1.5.2' to my app/build.gradle:
code :
dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.0'
    compile 'com.android.support:design:23.1.0'
    compile 'com.google.android.exoplayer:exoplayer:r1.5.2'
}
$ ./gradlew build
distributionUrl=https\://services.gradle.org/distributions/gradle-2.6-all.zip

How to use MediaSession extension for ExoPlayer v2.5+


By : rkartje
Date : March 29 2020, 07:55 AM
around this issue Here is how I did this.
First initialize the MediaSessionCompat, MediaSessionConnector and MediaControllerCompat as given below.
code :
        private void initMediaSession(){
                ComponentName mediaButtonReceiver = new ComponentName(getApplicationContext(), MediaButtonReceiver.class);
                mMediaSessionCompat = new MediaSessionCompat(getApplicationContext(), "MyMediasession", mediaButtonReceiver, null);
MediaSessionConnector mediaSessionConnector = new MediaSessionConnector(mMediaSessionCompat, mPlaybackController, false);
                mediaSessionConnector.setPlayer(mMediaPlayerManager.getPlayer(), null);
                mMediaControllerCompat = mMediaSessionCompat.getController();
            }
private MediaSessionConnector.PlaybackController mPlaybackController = new MediaSessionConnector.PlaybackController() {

            @Override
            public long getSupportedPlaybackActions(@Nullable Player player) {

                long ACTIONS = PlaybackStateCompat.ACTION_PLAY_PAUSE | PlaybackStateCompat.ACTION_PLAY
                        | PlaybackStateCompat.ACTION_PAUSE | PlaybackStateCompat.ACTION_STOP;

                return ACTIONS;
            }

            @Override
            public void onPlay(Player player) {

            }

            @Override
            public void onPause(Player player) {

            }

            @Override
            public void onSeekTo(Player player, long position) {

            }

            @Override
            public void onFastForward(Player player) {

            }

            @Override
            public void onRewind(Player player) {

            }

            @Override
            public void onStop(Player player) {

            }

        };
mMediaControllerCompat.getTransportControls().play();//For play
mMediaControllerCompat.getTransportControls().pause();//For pause

android studio failed to resolve: runner and failed to resolve: espresso-core and failed to resolve: monitor


By : user1290748
Date : March 29 2020, 07:55 AM
hope this fix your issue Follow these steps:
Open Module setting for the application Under dependencies, tab Click on '+' Symbol and add all the required dependencies one by one Click on Apply button

Android dependency 'com.google.android.exoplayer:exoplayer' has different version for the compile (r2.1.0) and runtime (


By : Sachini Lanka
Date : March 29 2020, 07:55 AM
I think the issue was by ths following , run > gradlew androidDependencies command. Using control + F you can look for the conflicting sub-dependencies and thus discover which direct dependency it belongs to.

How to resolve this on Android Studio 3.0 Canary 1:Failed to resolve: com.google.android:android:2.3.1


By : Deadcluster
Date : March 29 2020, 07:55 AM
this will help Apparently the problem is with Anko, there's no compatibility yet with new Android Studio version. As suggested by m43bloe (refer to GitHub Anko issue) you can solve doing this:
Related Posts Related Posts :
  • http2 doesn't seem to be working with OkHttp3 and retrofit2
  • Failed to resolve: com.google.android:flexbox:1.1.0
  • How to fix Xiaomi specific RemoteServiceException with notification icon?
  • Placing text in the center of a CircularProgressIndicator
  • Calculator that accepts floating point values
  • Bitrise error Could not find com.google.gms:google-services:3.2.1
  • Check if Input is empty doesnt work Kotlin
  • Could not find method compile() for arguments [com.google.gms:google-services:4.0.0]
  • View AGPS setting in Android
  • Am I doing dependency injection in activity code correctly?
  • React Native Gradle ImagePicker wont build
  • React Native changes to code have no affect on emulator app?
  • Get the TextView value of the gridview while clicking on an element
  • How to launch an intent for a third party app?
  • Going crazy trying to change android theme on Xamarin.Forms
  • Could not find any matches for com.android.tools.build:gradle:2.3.+ as no versions of com.android.tools.build:gradle are
  • How can I capture variables inside of Context
  • React Native : Could not find com.android.tools.build:gradle:2.2.3
  • Google Login/Signin on Yandex Android extension
  • Retrofit generates wrong GET request parameters from Map<String : Any>
  • Flutter app crashing when opening first time with ClassNotFoundException on Android
  • Android LinearLayout programmatically one column left, one column float right
  • Kotlin - convert UTC to local time
  • Android'd ForegroundDispatch for NFC
  • How to use Shared Preferences in class to set all activities?
  • Synchronous Volley request locks up
  • How do I inherit a function from another class into an activity in kotlin?
  • BottomAppBar Navigation Icon with Badge
  • Change content_main XML in Basic Navigation Drawer Template
  • HERE SDK Android: PositioningManager not working with NETWORK_PROVIDER in 3.8 or 3.9
  • No response after putting in Header in request
  • Where are default shared preferences written to?
  • how to show a part of next image in daimajia slider?
  • AlertDialog Builder inside holder.itemView.setOnClickListener onBindViewHolder
  • Flutter Grid view is not scrolling
  • How to access view in addTextChangedListener?
  • How do I link multiple activities in android navigation editor?
  • ViewPager + Picasso + multiple images from URL String array
  • how do I open another fragment after selecting the image in recycler view?
  • Send data from fragment to another fragment
  • Custom TitleView with Description and Preview Image Android TV (FireTV)
  • Gradle project sync failed. basic functionality (e.g. editing debugging) will not work properly
  • how to retrieve firebase storage images in release mode?
  • Android Studio: Could not find matches as no versions of com.android.tools.build:gradle are available
  • Getting a JSON Left side Value
  • Is it possible to use of Mobile data while transferring file via Wi-Fi Direct?
  • Build Error: Could not find any version that matches com.android.tools.build:transform-api:1.5.+
  • Robolectric 4.0.2 test are not running in gradle 3.2.1 with NoSuchMethodError: setUseLegacyResources(Z)V
  • How to be notified of another app's crash?
  • Could not find com.android.tools.build:gradle:2.2.3
  • Recyclerview scroll to empty Edit Text
  • How to set applicationID using Android.mk
  • Firebase: How to implement "take action only when another device is online"?
  • Can not find attribute app:useSimpleSummaryProvider
  • Relation between buffers and glVertexAttribPointer
  • Android - focus navigation back button
  • Disable WiFi option in Google Text To Speech (TTS) programmatically
  • using AdapterViewFlipper in a fragment in order to create image slider
  • How to add animation before the opening of a new activity?
  • Integrating Google Calendar API
  • shadow
    Privacy Policy - Terms - Contact Us © voile276.org